const regex = new RegExp('(?<=\\[)[^\\[\\]]+(?=\\])(?#This matches anything DIRECTLY between two square brackets)', 'gm')
const str = `abcd[bddb]xyyx
abba[mnop]qrst
abba[mnop[ibbi]abba]qrts
`;
const subst = `gaylmao`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);