# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\[)[^\[\]]+(?=\])(?#This matches anything DIRECTLY between two square brackets)/gaylmao/gm;t' <<< "abcd[bddb]xyyx
abba[mnop]qrst
abba[mnop[ibbi]abba]qrts
"