import Foundation
let pattern = ##"(?:\{-#){1}\w+(?:#-}){1}.*(?:\{-#){1}\w+(?:#-}){1}"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
{-#stepone#-}
<p>email</p>
<FORM method="POST" action="register.php?act=2">
<input type="text" name="email" placeholder="enter email" value=""></input>
<input type="submit" value="submit"></input>
</FORM>
{-#stepone#-}
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}