using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\{-#){1}\w+(?:#-}){1}.*(?:\{-#){1}\w+(?:#-}){1}";
string input = @"{-#stepone#-}
<p>email</p>
<FORM method=""POST"" action=""register.php?act=2"">
<input type=""text"" name=""email"" placeholder=""enter email"" value=""></input>
<input type=""submit"" value=""submit""></input>
</FORM>
{-#stepone#-}";
RegexOptions options = RegexOptions.Multiline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}