const regex = /(?:\{-#){1}\w+(?:#-}){1}.*(?:\{-#){1}\w+(?:#-}){1}/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\{-#){1}\\w+(?:#-}){1}.*(?:\\{-#){1}\\w+(?:#-}){1}', 'm')
const str = `{-#stepone#-}
<p>email</p>
<FORM method="POST" action="register.php?act=2">
<input type="text" name="email" placeholder="enter email" value=""></input>
<input type="submit" value="submit"></input>
</FORM>
{-#stepone#-}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}