import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\{-#){1}\\w+(?:#-\\}){1}.*(?:\\{-#){1}\\w+(?:#-\\}){1}";
final String string = "{-#stepone#-}\n"
+ " <p>email</p>\n"
+ " <FORM method=\"POST\" action=\"register.php?act=2\">\n"
+ " <input type=\"text\" name=\"email\" placeholder=\"enter email\" value=\"\"></input>\n"
+ " <input type=\"submit\" value=\"submit\"></input>\n"
+ " </FORM>\n"
+ "{-#stepone#-}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}