#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\{-#){1}\w+(?:#-}){1}.*(?:\{-#){1}\w+(?:#-}){1}"
Local $sString = "{-#stepone#-}" & @CRLF & _
" <p>email</p>" & @CRLF & _
" <FORM method="POST" action="register.php?act=2">" & @CRLF & _
" <input type="text" name="email" placeholder="enter email" value=""></input>" & @CRLF & _
" <input type="submit" value="submit"></input>" & @CRLF & _
" </FORM>" & @CRLF & _
"{-#stepone#-}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")