$re = '/(?:\{-#){1}\w+(?:#-}){1}.*(?:\{-#){1}\w+(?:#-}){1}/m';
$str = '{-#stepone#-}
<p>email</p>
<FORM method="POST" action="register.php?act=2">
<input type="text" name="email" placeholder="enter email" value=""></input>
<input type="submit" value="submit"></input>
</FORM>
{-#stepone#-}';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);