use strict;
my $str = '{-#stepone#-}
<p>email</p>
<FORM method="POST" action="register.php?act=2">
<input type="text" name="email" placeholder="enter email" value=""></input>
<input type="submit" value="submit"></input>
</FORM>
{-#stepone#-}';
my $regex = qr/(?:\{-#){1}\w+(?:#-}){1}.*(?:\{-#){1}\w+(?:#-}){1}/mp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}