// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\{[^\}]+\}").unwrap();
let string = "sdfgsdfgsdfg sdfg dsfg sdfg sdfg dsfg dsfg sd
sdfgsdfgsdfg
\"!@#$%¨&*()_+
´~'\"°ºª
´~.,;<>:/*-+.,¹²³£¢¬§\"
!@#$%¨&*()_+
'1234567890-
ssdfg
{
JoaoFabioMA
Hugo
sdfgsdfgsdfg
\"!@#$%¨&*()_+
´~'\"°ºª
´~.,;<>:/*-+.,¹²³£¢¬§\"
!@#$%¨&*()_+
'1234567890-
ssdfg
}
sdfgdsf
\"!@#$%¨&*()_+
dsfgdfg
{
/*
JoaoFabioMA
sdfgsdfgsdfg
\"!@#$%¨&*()_+
´~'\"°ºª
´~.,;<>:/*-+.,¹²³£¢¬§\"
!@#$%¨&*()_+
'1234567890-
ssdfg
Hugo
*/
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}