#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\{[^\}]+\}"
Local $sString = "sdfgsdfgsdfg sdfg dsfg sdfg sdfg dsfg dsfg sd" & @CRLF & _
"sdfgsdfgsdfg" & @CRLF & _
""!@#$%¨&*()_+" & @CRLF & _
"´~'"°ºª" & @CRLF & _
"´~.,;<>:/*-+.,¹²³£¢¬§"" & @CRLF & _
"!@#$%¨&*()_+" & @CRLF & _
"'1234567890-" & @CRLF & _
"ssdfg" & @CRLF & _
"{" & @CRLF & _
"JoaoFabioMA" & @CRLF & _
"Hugo" & @CRLF & _
"sdfgsdfgsdfg" & @CRLF & _
""!@#$%¨&*()_+" & @CRLF & _
"´~'"°ºª" & @CRLF & _
"´~.,;<>:/*-+.,¹²³£¢¬§"" & @CRLF & _
"!@#$%¨&*()_+" & @CRLF & _
"'1234567890-" & @CRLF & _
"ssdfg" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"sdfgdsf" & @CRLF & _
""!@#$%¨&*()_+" & @CRLF & _
"dsfgdfg" & @CRLF & _
"{" & @CRLF & _
"/*" & @CRLF & _
"JoaoFabioMA" & @CRLF & _
"sdfgsdfgsdfg" & @CRLF & _
""!@#$%¨&*()_+" & @CRLF & _
"´~'"°ºª" & @CRLF & _
"´~.,;<>:/*-+.,¹²³£¢¬§"" & @CRLF & _
"!@#$%¨&*()_+" & @CRLF & _
"'1234567890-" & @CRLF & _
"ssdfg" & @CRLF & _
"Hugo" & @CRLF & _
"" & @CRLF & _
"*/" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")