using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\{[^\}]+\}";
string input = @"sdfgsdfgsdfg sdfg dsfg sdfg sdfg dsfg dsfg sd
sdfgsdfgsdfg
""!@#$%¨&*()_+
´~'""°ºª
´~.,;<>:/*-+.,¹²³£¢¬§""
!@#$%¨&*()_+
'1234567890-
ssdfg
{
JoaoFabioMA
Hugo
sdfgsdfgsdfg
""!@#$%¨&*()_+
´~'""°ºª
´~.,;<>:/*-+.,¹²³£¢¬§""
!@#$%¨&*()_+
'1234567890-
ssdfg
}
sdfgdsf
""!@#$%¨&*()_+
dsfgdfg
{
/*
JoaoFabioMA
sdfgsdfgsdfg
""!@#$%¨&*()_+
´~'""°ºª
´~.,;<>:/*-+.,¹²³£¢¬§""
!@#$%¨&*()_+
'1234567890-
ssdfg
Hugo
*/
}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}