$re = '/\{[^\}]+\}/';
$str = 'sdfgsdfgsdfg sdfg dsfg sdfg sdfg dsfg dsfg sd
sdfgsdfgsdfg
"!@#$%¨&*()_+
´~\'"°ºª
´~.,;<>:/*-+.,¹²³£¢¬§"
!@#$%¨&*()_+
\'1234567890-
ssdfg
{
JoaoFabioMA
Hugo
sdfgsdfgsdfg
"!@#$%¨&*()_+
´~\'"°ºª
´~.,;<>:/*-+.,¹²³£¢¬§"
!@#$%¨&*()_+
\'1234567890-
ssdfg
}
sdfgdsf
"!@#$%¨&*()_+
dsfgdfg
{
/*
JoaoFabioMA
sdfgsdfgsdfg
"!@#$%¨&*()_+
´~\'"°ºª
´~.,;<>:/*-+.,¹²³£¢¬§"
!@#$%¨&*()_+
\'1234567890-
ssdfg
Hugo
*/
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);