package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\{[^\}]+\}`)
var str = `sdfgsdfgsdfg sdfg dsfg sdfg sdfg dsfg dsfg sd
sdfgsdfgsdfg
"!@#$%¨&*()_+
´~'"°ºª
´~.,;<>:/*-+.,¹²³£¢¬§"
!@#$%¨&*()_+
'1234567890-
ssdfg
{
JoaoFabioMA
Hugo
sdfgsdfgsdfg
"!@#$%¨&*()_+
´~'"°ºª
´~.,;<>:/*-+.,¹²³£¢¬§"
!@#$%¨&*()_+
'1234567890-
ssdfg
}
sdfgdsf
"!@#$%¨&*()_+
dsfgdfg
{
/*
JoaoFabioMA
sdfgsdfgsdfg
"!@#$%¨&*()_+
´~'"°ºª
´~.,;<>:/*-+.,¹²³£¢¬§"
!@#$%¨&*()_+
'1234567890-
ssdfg
Hugo
*/
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}