import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{[^\\}]+\\}";
final String string = "sdfgsdfgsdfg sdfg dsfg sdfg sdfg dsfg dsfg sd\n"
+ "sdfgsdfgsdfg\n"
+ "\"!@#$%¨&*()_+\n"
+ "´~'\"°ºª\n"
+ "´~.,;<>:/*-+.,¹²³£¢¬§\"\n"
+ "!@#$%¨&*()_+\n"
+ "'1234567890-\n"
+ "ssdfg\n"
+ "{\n"
+ "JoaoFabioMA\n"
+ "Hugo\n"
+ "sdfgsdfgsdfg\n"
+ "\"!@#$%¨&*()_+\n"
+ "´~'\"°ºª\n"
+ "´~.,;<>:/*-+.,¹²³£¢¬§\"\n"
+ "!@#$%¨&*()_+\n"
+ "'1234567890-\n"
+ "ssdfg\n"
+ "}\n\n"
+ "sdfgdsf\n"
+ "\"!@#$%¨&*()_+\n"
+ "dsfgdfg\n"
+ "{\n"
+ "/*\n"
+ "JoaoFabioMA\n"
+ "sdfgsdfgsdfg\n"
+ "\"!@#$%¨&*()_+\n"
+ "´~'\"°ºª\n"
+ "´~.,;<>:/*-+.,¹²³£¢¬§\"\n"
+ "!@#$%¨&*()_+\n"
+ "'1234567890-\n"
+ "ssdfg\n"
+ "Hugo\n\n"
+ "*/\n"
+ "}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}