const regex = /\{[^\}]+\}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\{[^\\}]+\\}', 'g')
const str = `sdfgsdfgsdfg sdfg dsfg sdfg sdfg dsfg dsfg sd
sdfgsdfgsdfg
"!@#\$%¨&*()_+
´~'"°ºª
´~.,;<>:/*-+.,¹²³£¢¬§"
!@#\$%¨&*()_+
'1234567890-
ssdfg
{
JoaoFabioMA
Hugo
sdfgsdfgsdfg
"!@#\$%¨&*()_+
´~'"°ºª
´~.,;<>:/*-+.,¹²³£¢¬§"
!@#\$%¨&*()_+
'1234567890-
ssdfg
}
sdfgdsf
"!@#\$%¨&*()_+
dsfgdfg
{
/*
JoaoFabioMA
sdfgsdfgsdfg
"!@#\$%¨&*()_+
´~'"°ºª
´~.,;<>:/*-+.,¹²³£¢¬§"
!@#\$%¨&*()_+
'1234567890-
ssdfg
Hugo
*/
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}