import Foundation
let pattern = #"^(?:(?<S>((?<W>[^\x20\.\r\n\(\)]*)\x20)*\g<W>\.|\(\g<W>((\x20\g<W>)*)?\))(\x20\g<S>)*)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Este é o meu texto. Eu sou lindo e irresistível. (Versão portuguesa)
This is my text. I'm beautiful and irresistible. (English version)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)