$re = '/^(?:(?<S>((?<W>[^\x20\.\r\n\(\)]*)\x20)*\g<W>\.|\(\g<W>((\x20\g<W>)*)?\))(\x20\g<S>)*)?$/m';
$str = 'Este é o meu texto. Eu sou lindo e irresistível. (Versão portuguesa)
This is my text. I\'m beautiful and irresistible. (English version)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);