package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(?<S>((?<W>[^\x20\.\r\n\(\)]*)\x20)*\g<W>\.|\(\g<W>((\x20\g<W>)*)?\))(\x20\g<S>)*)?$`)
var str = `Este é o meu texto. Eu sou lindo e irresistível. (Versão portuguesa)
This is my text. I'm beautiful and irresistible. (English version)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}