const regex = /^(?:(?<S>((?<W>[^\x20\.\r\n\(\)]*)\x20)*\g<W>\.|\(\g<W>((\x20\g<W>)*)?\))(\x20\g<S>)*)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?<S>((?<W>[^\\x20\\.\\r\\n\\(\\)]*)\\x20)*\\g<W>\\.|\\(\\g<W>((\\x20\\g<W>)*)?\\))(\\x20\\g<S>)*)?$', 'gm')
const str = `Este é o meu texto. Eu sou lindo e irresistível. (Versão portuguesa)
This is my text. I'm beautiful and irresistible. (English version)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}