use strict;
my $str = 'Este é o meu texto. Eu sou lindo e irresistível. (Versão portuguesa)
This is my text. I\'m beautiful and irresistible. (English version)';
my $regex = qr/^(?:(?<S>((?<W>[^\x20\.\r\n\(\)]*)\x20)*\g<W>\.|\(\g<W>((\x20\g<W>)*)?\))(\x20\g<S>)*)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}