re = /^(?:(?<S>((?<W>[^\x20\.\r\n\(\)]*)\x20)*\g<W>\.|\(\g<W>((\x20\g<W>)*)?\))(\x20\g<S>)*)?$/m
str = 'Este é o meu texto. Eu sou lindo e irresistível. (Versão portuguesa)
This is my text. I\'m beautiful and irresistible. (English version)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end