import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?<S>((?<W>[^\\x20\\.\\r\\n\\(\\)]*)\\x20)*\\g<W>\\.|\\(\\g<W>((\\x20\\g<W>)*)?\\))(\\x20\\g<S>)*)?$";
final String string = "Este é o meu texto. Eu sou lindo e irresistível. (Versão portuguesa)\n"
+ "This is my text. I'm beautiful and irresistible. (English version)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}