import Foundation
let pattern = #"time\(.*\)=(\d*(?:\.\d*)?)s"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
time(c:\Program Files\10.0\2\c1xx.exe)=0.23609s < 377648803844 - 377654889334 >
time(c:\Program Files\10.0\2\c1xx.exe)=004421.s < 377648803844 - 377654889334 >
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)