re = /time\(.*\)=(\d*(?:\.\d*)?)s/m
str = ' time(c:\\Program Files\\10.0\\2\\c1xx.exe)=0.23609s < 377648803844 - 377654889334 >
time(c:\\Program Files\\10.0\\2\\c1xx.exe)=004421.s < 377648803844 - 377654889334 >
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end