package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)time\(.*\)=(\d*(?:\.\d*)?)s`)
var str = ` time(c:\Program Files\10.0\2\c1xx.exe)=0.23609s < 377648803844 - 377654889334 >
time(c:\Program Files\10.0\2\c1xx.exe)=004421.s < 377648803844 - 377654889334 >
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}