#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)time\(.*\)=(\d*(?:\.\d*)?)s"
Local $sString = " time(c:\Program Files\10.0\2\c1xx.exe)=0.23609s < 377648803844 - 377654889334 >" & @CRLF & _
" time(c:\Program Files\10.0\2\c1xx.exe)=004421.s < 377648803844 - 377654889334 >" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")