use strict;
my $str = ' time(c:\\Program Files\\10.0\\2\\c1xx.exe)=0.23609s < 377648803844 - 377654889334 >
time(c:\\Program Files\\10.0\\2\\c1xx.exe)=004421.s < 377648803844 - 377654889334 >
';
my $regex = qr/time\(.*\)=(\d*(?:\.\d*)?)s/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}