import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "time\\(.*\\)=(\\d*(?:\\.\\d*)?)s";
final String string = " time(c:\\Program Files\\10.0\\2\\c1xx.exe)=0.23609s < 377648803844 - 377654889334 >\n"
+ " time(c:\\Program Files\\10.0\\2\\c1xx.exe)=004421.s < 377648803844 - 377654889334 >\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}