$re = '/time\(.*\)=(\d*(?:\.\d*)?)s/m';
$str = ' time(c:\\Program Files\\10.0\\2\\c1xx.exe)=0.23609s < 377648803844 - 377654889334 >
time(c:\\Program Files\\10.0\\2\\c1xx.exe)=004421.s < 377648803844 - 377654889334 >
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);