// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?i).* msiexec.*:\\\\").unwrap();
let string = "cmd.exe msiexec.exe:\\\\ someprogram -argument \"stuff\"
MSI Exec Web install
SysmonEvent | where (EventID == 1 and (CommandLine matches regex @'(?i).* msiexec.*:\\\\/\\\\/.*'))
SecurityEvent | where (EventID == 4688 and (ProcessCommandLine matches regex @'(?i).* msiexec.*:\\\\/\\\\/.*'))";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}