package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i).* msiexec.*:\\\\`)
var str = `cmd.exe msiexec.exe:\\ someprogram -argument "stuff"
MSI Exec Web install
SysmonEvent | where (EventID == 1 and (CommandLine matches regex @'(?i).* msiexec.*:\\/\\/.*'))
SecurityEvent | where (EventID == 4688 and (ProcessCommandLine matches regex @'(?i).* msiexec.*:\\/\\/.*'))`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}