re = /(?i).* msiexec.*:\\\\/m
str = 'cmd.exe msiexec.exe:\\\\ someprogram -argument "stuff"
MSI Exec Web install
SysmonEvent | where (EventID == 1 and (CommandLine matches regex @\'(?i).* msiexec.*:\\\\/\\\\/.*\'))
SecurityEvent | where (EventID == 4688 and (ProcessCommandLine matches regex @\'(?i).* msiexec.*:\\\\/\\\\/.*\'))'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end