#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i).* msiexec.*:\\\\"
Local $sString = "cmd.exe msiexec.exe:\\ someprogram -argument "stuff"" & @CRLF & _
"" & @CRLF & _
"MSI Exec Web install" & @CRLF & _
"SysmonEvent | where (EventID == 1 and (CommandLine matches regex @'(?i).* msiexec.*:\\/\\/.*'))" & @CRLF & _
"SecurityEvent | where (EventID == 4688 and (ProcessCommandLine matches regex @'(?i).* msiexec.*:\\/\\/.*'))"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")