const regex = /(?i).* msiexec.*:\\\\/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i).* msiexec.*:\\\\\\\\', 'gm')
const str = `cmd.exe msiexec.exe:\\\\ someprogram -argument "stuff"
MSI Exec Web install
SysmonEvent | where (EventID == 1 and (CommandLine matches regex @'(?i).* msiexec.*:\\\\/\\\\/.*'))
SecurityEvent | where (EventID == 4688 and (ProcessCommandLine matches regex @'(?i).* msiexec.*:\\\\/\\\\/.*'))`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}