use strict;
my $str = 'cmd.exe msiexec.exe:\\\\ someprogram -argument "stuff"
MSI Exec Web install
SysmonEvent | where (EventID == 1 and (CommandLine matches regex @\'(?i).* msiexec.*:\\\\/\\\\/.*\'))
SecurityEvent | where (EventID == 4688 and (ProcessCommandLine matches regex @\'(?i).* msiexec.*:\\\\/\\\\/.*\'))';
my $regex = qr/(?i).* msiexec.*:\\\\/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}