$re = '/(?i).* msiexec.*:\\\\\\\\/m';
$str = 'cmd.exe msiexec.exe:\\\\ someprogram -argument "stuff"
MSI Exec Web install
SysmonEvent | where (EventID == 1 and (CommandLine matches regex @\'(?i).* msiexec.*:\\\\/\\\\/.*\'))
SecurityEvent | where (EventID == 4688 and (ProcessCommandLine matches regex @\'(?i).* msiexec.*:\\\\/\\\\/.*\'))';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);