import Foundation
let pattern = #"[^0-9.]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
3040.302
$15,405.20
10.10,10.8,-10.9
"ele10.34.5642"
"104fflkd104.35 df10dw4.70"
"$10,000,000.04"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}