#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[^0-9.]"
Local $sString = "3040.302" & @CRLF & _
"$15,405.20" & @CRLF & _
"10.10,10.8,-10.9" & @CRLF & _
""ele10.34.5642"" & @CRLF & _
""104fflkd104.35 df10dw4.70"" & @CRLF & _
""$10,000,000.04""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")