package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^0-9.]`)
var str = `3040.302
$15,405.20
10.10,10.8,-10.9
"ele10.34.5642"
"104fflkd104.35 df10dw4.70"
"$10,000,000.04"`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}