const regex = /[^0-9.]/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^0-9.]', '')
const str = `3040.302
\$15,405.20
10.10,10.8,-10.9
"ele10.34.5642"
"104fflkd104.35 df10dw4.70"
"\$10,000,000.04"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}