// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[^0-9.]").unwrap();
let string = "3040.302
$15,405.20
10.10,10.8,-10.9
\"ele10.34.5642\"
\"104fflkd104.35 df10dw4.70\"
\"$10,000,000.04\"";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}