import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^0-9.]";
final String string = "3040.302\n"
+ "$15,405.20\n"
+ "10.10,10.8,-10.9\n"
+ "\"ele10.34.5642\"\n"
+ "\"104fflkd104.35 df10dw4.70\"\n"
+ "\"$10,000,000.04\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}