re = /[^0-9.]/
str = '3040.302
$15,405.20
10.10,10.8,-10.9
"ele10.34.5642"
"104fflkd104.35 df10dw4.70"
"$10,000,000.04"'
# Print the match result
str.match(re) do |match|
puts match.to_s
end