// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)\d{1,2}\-\d{1,2}\-\d{2,4}").unwrap();
let string = "1-1-18
01-01-2018
1-01-2018
01-1-2018
01-01-18
01-1-18
1-01-18
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}