$re = ';\d{1,2}\-\d{1,2}\-\d{2,4};mi';
$str = '1-1-18
01-01-2018
1-01-2018
01-1-2018
01-01-18
01-1-18
1-01-18
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);