#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)\d{1,2}\-\d{1,2}\-\d{2,4}"
Local $sString = "1-1-18" & @CRLF & _
"01-01-2018" & @CRLF & _
"1-01-2018" & @CRLF & _
"01-1-2018" & @CRLF & _
"01-01-18" & @CRLF & _
"01-1-18" & @CRLF & _
"1-01-18" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")