re = /\d{1,2}\-\d{1,2}\-\d{2,4}/mi
str = '1-1-18
01-01-2018
1-01-2018
01-1-2018
01-01-18
01-1-18
1-01-18
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end