import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d{1,2}\\-\\d{1,2}\\-\\d{2,4}";
final String string = "1-1-18\n"
+ "01-01-2018\n"
+ "1-01-2018\n"
+ "01-1-2018\n"
+ "01-01-18\n"
+ "01-1-18\n"
+ "1-01-18\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}