use strict;
my $str = '1-1-18
01-01-2018
1-01-2018
01-1-2018
01-01-18
01-1-18
1-01-18
';
my $regex = qr;\d{1,2}\-\d{1,2}\-\d{2,4};mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}